We are continuing to monitor for any further issues.
Posted Mar 20, 2026 - 15:46 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 20, 2026 - 15:46 UTC
Update
We are continuing to work on a fix for this issue.
Posted Mar 20, 2026 - 15:39 UTC
Identified
We are currently investigating an issue affecting connectivity between our kiosks and a third-party system. This may impact certain transactions.
To restore normal operation, we will be performing a controlled system maintenance action shortly. During this time, there may be a brief interruption in service.
We will provide updates as progress is made and confirm once services are fully restored.