A fix has been implemented and we are monitoring the results.
Posted Sep 09, 2026 - 19:26 UTC
Identified
The cause has been traced to a change in Microsoft Windows Update KB5124008. Our team has applied the fix to approximately half the affected kiosks and we are currently working on fixing the remaining kiosks.
Posted Sep 09, 2026 - 17:44 UTC
Investigating
We are investigating reports of some kiosks displaying a blank screen. Kiosks are otherwise online and reachable. We have identified a likely cause and are working on a fix. Next update within 2 hours.