Verification is currently underway for the maintenance items.
Posted Feb 26, 2025 - 19:19 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Feb 26, 2025 - 19:15 UTC
Scheduled
Meridian is conducting maintenance for some of our Mzero reporting endpoints. During the maintenance window, there could be brief delays affecting kiosk report processing from some accounts.